设为首页收藏本站加入Q群 隐藏访客:

末心网安论坛

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 100|回复: 2

易语言如果真的应用

[复制链接]

59

主题

74

帖子

494

积分

版主

Rank: 7Rank: 7Rank: 7

积分
494
发表于 2020-3-31 17:42:09 | 显示全部楼层 |阅读模式
一日五更系列

1.如果真的使用
如果真(编辑框1.内容=“123456789”)‘这里是执行下面命令的条件 不满足这个就不能执行  编辑框1.内容=“123456789”  就是条件
      编辑框1.内容=“”       ’这是满足条件以后执行的命令   复制到易语言里面   看到左边的虚线了吗        要执行的命令要写在虚线的右边    如果在虚线的下方写 就不需要满足这个条件了


2.如果的使用

.版本 2
.子程序 _按钮1_被单击
.如果 (编辑框1.内容 = “1”)  ' 判断编辑框1的内容是否等于1
    信息框 (“有内容”, 0, “提示:”)  ' 如果等于1就弹出信息框
.否则
    信息框 (“无内容”, 0, “提示”)  ' 如果不等于1就弹出信息框

3.或 或者与如果的连用
或和或者是一个意思。
比如:.版本 2.如果真 (编辑框1.内容 = “123” 或 编辑框1.内容 = “456”) 信息框 (“你输入的正确”, #信息图标, )
返回 ().
如果真结束信息框 (“您输入的错误”, #错误图标, )
有一点注意,或者的命令一个是按上面那么写,
另一种 如果真(或者(编辑框1.内容=“123,或者 编辑框.内容=“456”)) 当你敲回车的时候,会自动转换成上面的样子。
关于易语言补充(下面是正文,只是作者第一篇文章忘了而已,补充一下)
易语言是一个自主开发,适合国情,不同层次不同专业的人员易学易用的汉语编程语言。易语言降低了广大电脑用户编程的门槛,尤其是根本不懂英文或者英文了解很少的用户,可以通过使用本语言极其快速地进入Windows程序编写的大门。易语言汉语编程环境是一个支持基于汉语字、词编程的、全可视化的、跨主流操作系统平台的编程工具环境;拥有简、繁汉语以及英语、日语等多语种版本;能与常用的编程语言互相调用;具有充分利用API,COM、DLL、OCX组件,各种主流数据库,各种实用程序等多种资源的接口和支撑工具。易语言有自主开发的高质量编译器,中文源代码被直接编译为CPU指令,运行效率高,安全可信性高;拥有自己的数据库系统,且支持访问现有所有数据库;内置专用输入法,支持中文语句快速录入,完全解决了中文输入慢的问题;易语言除了支持界面设计的可视化,还支持程序流程的即时可视化;除了语句的中文化之外,易语言中还专门提供了适合中国国情的命令,如中文格式日期和时间处理、汉字发音处理、全半角字符处理、人民币金额的处理等;易语言综合采用了结构化、面向对象、组件、构架、集成化等多种先进技术,并在运行效率、性能价格比、全可视化支持、适应本地化需要、面向对象以及提供Windows,Linux上的运行平台等具有特色;现有各种支持库多达40多个,用户可以使用它来满足几乎所有的Windows编程需求,多媒体功能支持强大,完善的网络、端口通讯和互联网功能支持,网上与论坛上的学习资源众多。在易语言及其编译器的设计与实现、可视化汉语编程的构建、提供多种语言版本等方面具有创新。易语言已取得国家级鉴定,鉴定会专家一致认为:易语言在技术上居于国内领先地位,达到了当前同类产品的国际先进水平。
END……


回复

使用道具 举报

1

主题

3

帖子

21

积分

版主

Rank: 7Rank: 7Rank: 7

积分
21
发表于 2020-4-3 16:20:25 | 显示全部楼层
最好先从输入输出,变量常量,运算符开始讲,“如果”是属于条件控制,应该后讲。
回复 支持 反对

使用道具 举报

59

主题

74

帖子

494

积分

版主

Rank: 7Rank: 7Rank: 7

积分
494
 楼主| 发表于 2020-4-4 19:48:23 | 显示全部楼层
感谢您对我文章的支持,谢谢
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Loading...

QQ|Archiver|手机版|小黑屋|末心网安论坛 ( 豫ICP备18034569号-1 )|网站地图

GMT+8, 2020-7-13 02:07 , Processed in 1.742076 second(s), 34 queries .

Powered by Discuz! X3.4

© 2001-2012 Comsenz Inc.. 技术支持 by 巅峰设计

快速回复 返回顶部 返回列表