设为首页收藏本站加入Q群 隐藏访客:

末心网安论坛

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 53|回复: 0

易语言学习精品教程

[复制链接]

59

主题

74

帖子

494

积分

版主

Rank: 7Rank: 7Rank: 7

积分
494
发表于 2020-4-1 15:57:24 | 显示全部楼层 |阅读模式
易语言且怎么用
执行判断时,连接2个或2个以上条件的时候使用

条件1 且 条件2   
只有条件1和条件2都满足的情况下才返回真,否则返回假
与之对应的是 或
条件1 或 条件2
任意一个条件满足的情况下都会返回真,所有条件都没满足时返回假
1234567891011121314    调用格式: 〈逻辑型〉 并且 (逻辑型 逻辑值一,逻辑型 逻辑值二,... ) - 系统核心支持库->逻辑比较    英文名称:and    如果所提供的两个参数逻辑值都为真则返回真,否则返回假,运算符号为“&&”或“And”或“且”。本命令为初级命令。命令参数表中最后一个参数可以被重复添加。    参数<1>的名称为“逻辑值一”,类型为“逻辑型(bool)”。    参数<2>的名称为“逻辑值二”,类型为“逻辑型(bool)”。


运行时易语言的组合框里有百度和hao123,当用户选中百度。再点击按钮1时,就打开baidu.com
当用户选中hao123。再点击按钮1时,就打开hao123.com

源码如下:
.版本 2

.子程序 _按钮1_被单击

.判断开始 (组合框1.取项目文本 (组合框1.现行选中项) = “百度”)
    ' 要完成的操作,例如打开www.baidu.com
.判断 (组合框1.取项目文本 (组合框1.现行选中项) = “hao123”)
    ' 要完成的操作,例如打开www.hao123.com
.默认

.判断结束
提示:先添加一个组合框,然后在组合框的属性里面,选择列表项目,然后插入你要求的[百度,hao123]等项目,在按钮单击事件里添加代码,你可以做一个判断,取出列表项目当前选择项,如果是(百度),就打开百度,如果是(hao123)就打开hao123。


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Loading...

QQ|Archiver|手机版|小黑屋|末心网安论坛 ( 豫ICP备18034569号-1 )|网站地图

GMT+8, 2020-7-13 02:39 , Processed in 1.414116 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2012 Comsenz Inc.. 技术支持 by 巅峰设计

快速回复 返回顶部 返回列表